Jump to content
BANGKOK 24 January 2019 12:09
topt

Wi fi connections - Where a log in screen required but do not see?

Recommended Posts

Samsung Galaxy S11 - yes very old.

Rooted and all Google apps removed along with many apks that did not appear to effect my use.........

Using DuckDuckGo as search engine, AFWall and Greenify.

 

I can normally connect to most available wi-fi by putting in the usual password without any issues. One regular haunt changed their wi fi and now it is supposed to come up with a log in screen which does not happen on my phone. Even more strangely this also happened with my laptop whereas previously I could access the internet without any issues.

My device shows as connected but there is no Internet - and Line says it cannot connect and find another connection.

 

The same thing happened at a hotel I stayed at last week (phone only as laptop not with me) and a golfing colleague had the same issue with his slightly more recent Samsung (S3 or 4 I think). I tried switching off AF Wall and then did see a notification about needing to log in to the specific named hotel wi fi which had not appeared before.

 

Anybody have an idea of which apk I may have removed that would cause this or what app I need to see it? As far as I know my colleague's phone was still stock and I am even more confused with why my laptop would not come up with anything.

Any other possible reasons or solutions?

Share this post


Link to post
Share on other sites

On the laptop, clear the browser cache and try. If it works, enter the address manually on the phone browser.

 

Edit

Have a look here too

Edited by ravip

Share this post


Link to post
Share on other sites

Are you getting the correct SSID? If you are you can opt to 'forget' that connection then either restart networking or reboot (or what ever you system needs to clear the data.) Then search again for the same SSID. And try to connect and see if it asks you for the password.

Share this post


Link to post
Share on other sites

If they are using "captive portal"
You need to start a web browser and input login details there.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, jmd8800 said:

Are you getting the correct SSID? If you are you can opt to 'forget' that connection then either restart networking or reboot (or what ever you system needs to clear the data.) Then search again for the same SSID. And try to connect and see if it asks you for the password.

Yes as I said I can connect but the log in screen/portal is not opening

Tried all you mentioned.

1 hour ago, johng said:

If they are using "captive portal"
You need to start a web browser and input login details there.

Tried that as well - but of course just no connection to Internet and nothing comes up.

Share this post


Link to post
Share on other sites
3 hours ago, ravip said:

On the laptop, clear the browser cache and try. If it works, enter the address manually on the phone browser.

 

Edit

Have a look here too

Tried that on my laptop before but no joy and have connected to login screens before at other places. I will try a couple of the things mentioned in your link - thanks for that.

I have a feeling it is tied to my browser and some sort of permission on the phone but I will need to side load another mobile browser apk to check it.

  • Like 1

Share this post


Link to post
Share on other sites

Does your service provider give you wi-fi at various locations like popular shopping malls?  When I had the same issue with AIS wi-fi log-in, I stopped by an AIS location and they sorted it out.  Never had the issue again.

Share this post


Link to post
Share on other sites
8 hours ago, dddave said:

Does your service provider give you wi-fi at various locations like popular shopping malls?  When I had the same issue with AIS wi-fi log-in, I stopped by an AIS location and they sorted it out.  Never had the issue again.

Thanks but no. This is just connecting with wi fi to bars/hotels/coffee shops free wi fi with a password.

Share this post


Link to post
Share on other sites
6 hours ago, VBF said:

A friend of mine had this issue and i put together a "cheat sheet" to fix it.

Please see attached document and be so kind as to let me know which, if any solution, works for you.

 

 

 

Here’s how to manually access a public WiFi login page on Android.docx

Thanks. Although I think I tried most of what was mentioned I will give it another go next time I am in there and let you know.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 12/12/2018 at 2:59 PM, VBF said:

and be so kind as to let me know which, if any solution, works for you.

I had some free time today so went in earlier and resolved it - possibly not permanently on the phone.

 

Sorted the laptop first and found all I needed to do was knock the s off https:// on the web address on my browser and it opened up the login screen. 

 

Mobile - I had loaded 2 new web browsers and after removing the firewall it asked me to choose which browser I wanted to open (but did not come up with my existing DuckDuckGo browser?) which then opened to the log in screen. However this appeared to save the login to the browser and not to the phone but will find out next time I am there.

 

One of the things I have discovered today is that I do not appear to be able to set any browsers I have to be the default browser. The default settings are all greyed out, in fact this is the case on every app except Messaging which is still the original Samsung app.

 

Edit - I switched AF Wall back on after connecting and I still had internet access.

Edited by topt

Share this post


Link to post
Share on other sites
50 minutes ago, topt said:

I had some free time today so went in earlier and resolved it - possibly not permanently on the phone.

 

Sorted the laptop first and found all I needed to do was knock the s off https:// on the web address on my browser and it opened up the login screen. 

 

Mobile - I had loaded 2 new web browsers and after removing the firewall it asked me to choose which browser I wanted to open (but did not come up with my existing DuckDuckGo browser?) which then opened to the log in screen. However this appeared to save the login to the browser and not to the phone but will find out next time I am there.

 

One of the things I have discovered today is that I do not appear to be able to set any browsers I have to be the default browser. The default settings are all greyed out, in fact this is the case on every app except Messaging which is still the original Samsung app.

 

Thanks for updating. In order:

On the laptop, that https: issue is a good find - i've updated my "cheat sheet" 👍

On the mobile - yes I do suggest trying another browser in my sheet - no matter - you got there.

 

I'm not sure what you meant by ".....this appeared to save the login to the browser and not to the phone.....".

AFAIK, the only browser that will actually save your details to the phone's account is Chrome, because Chrome is Google and so is Android, therefore your phone's account is actually a Google Account, assuming you chose the default option to log into Google

 

So for example my Android phones and tablets and Windows PCs are synched VIA my Google account but the PC is only synched  if I'm using Chrome on the PC. Useful if I want all my bookmarks etc to align. If I wish to be a little more anonymous, I use Edge on the PC. The PC itself is NOT logged into anything except my own network - certainly not Microsoft!

 

And...... when you mention default browsers, are you referring to the phone (Android) or the laptop (Windows)? If the latter (Windows), it's a known problem surrounding Windows 10 updates and I may be able to point you to a solution.

 

If it's Android - I wasn't sure but I found this https://support.mozilla.org/en-US/kb/make-firefox-default-browser-android 

It actually refers to using Firefox but the general principles remain the same - I've just followed it through on an Android device that has 2 browsers installed.

 

Let us know once again please.

Edited by VBF

Share this post


Link to post
Share on other sites
26 minutes ago, VBF said:

And...... when you mention default browsers, are you referring to the phone (Android)

Yes - I had seen the Firefox details you linked to but as I mentioned every app on the phone  just above Permissions, header "Launch by default" says "No defaults set" except for the Messaging app. 

I have no Google at all (including the original account) on the phone - except now I find it is the search engine used on the two browsers I downloaded so they will be going shortly!

 

When I say "saved the login" I was referring to with a normal wi fi connection where the phone wi fi connection asks if you want to remember it. Here it was asking to save the details in the web browser - so I think I will need to reconnect each time I go there but we shall see. It may just be because my Android version is 4.1.2 but a friend today said he could not get another guys Samsung to connect to the log in screen at this location either. 

Share this post


Link to post
Share on other sites
1 hour ago, topt said:

Yes - I had seen the Firefox details you linked to but as I mentioned every app on the phone  just above Permissions, header "Launch by default" says "No defaults set" except for the Messaging app. 

I have no Google at all (including the original account) on the phone - except now I find it is the search engine used on the two browsers I downloaded so they will be going shortly!

 

When I say "saved the login" I was referring to with a normal wi fi connection where the phone wi fi connection asks if you want to remember it. Here it was asking to save the details in the web browser - so I think I will need to reconnect each time I go there but we shall see. It may just be because my Android version is 4.1.2 but a friend today said he could not get another guys Samsung to connect to the log in screen at this location either. 

I guess you're not a Google fan! 🤔 In that case ignore most of what I said above.

 

As you know, saving the WiFi connection's details is separate from the so-called Portal login - in a hotel I use, I can connect to the WifI and my phone remembers it, but I still need to login via the browser to actually USE it even if I'm not then going to use the browser, per se. IMO a silly way of implementing it but it is what it is.

 

Anyway you seem to pretty much have it sorted.😎

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Sponsors
×