Jump to content
BANGKOK
oldcpu

Thunderbird email program Thai font fix

Recommended Posts

Posted (edited)

I am posting this in case this solution helps anyone else using Thunderbird email program and Thai fonts.

 

My Thai wife was struggling to get Thai fonts to work on her computer with Thunderbird email program.   Every time she sent an email the Thai fonts were changed to question marks.  Now while she uses Windows-10, I was able to 100% reproduce the problem with Thunderbird on openSUSE GNU/Linux Leap-15.0  (i.e. I had the same problem with GNU/Linux Thunderbird).  We tried many different advice on the internet to solve this, and the only fix we could find was the following (for GNU/Linux).

 

In GNU/Linux Thunderbird go to :   Edit > Preferences > Advanced > Config Editor >  ... select YES to accept the risk ... > search for "mail.strictly" and change "mail.strictly_mime" to "true".  Close the window.  After this the Thai font correctly transmitted in the email.

 

For any MS-Windows users =>  after seeing the GNU/Linux fix, my wife in Windows-10 my wife did something similar in Thunderbird:   Tools > options > Advanced > Config Editor >  ... select YES to accept the risk ... > search for "mail.strictly" and change "mail.strictly_mime" to "true".  Close the window.  After this the Thai font correctly transmitted in the email.

Edited by oldcpu
  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for your helpful post!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...