Jump to content
Thai Visa Forum

Synchronization with time servers fails. 3BB issue?


Recommended Posts

I noticed my two laptops, a Windows 7 and a Windows 10, times were offset by nearly 2 minutes. This creates a problem when I need to sync files between the two of them and the timestamps of the files are off.

 

When I tried to manually force a time sync with internet time servers both laptops failed to sync. I tried the time servers that are default with Windows as well as trying asia.pool.ntp.org

 

We have 3BB internet and the strange thing is if I use a VPN, US ip address, the times sync quickly. I have had other issues in the past with various websites timing out mainly banking sites when using 3BB. I could connect to those sites without a problem using my phone as a hotspot.

 

I have the workaround of using a VPN but its still a curiosity. I wonder if anyone else using 3BB without a connection to a VPN has the problem.

 

Windows 10:
Click the clock then "Date and time settings" (at bottom of clock window)
This will show the date and time of last successful synchronization

You can click "Sync now" button to see if it updates correctly.

Link to post
Share on other sites

I remember having NTP issues when relying on 3BB as my primary connection several years ago. 

 

Try pinging any of these and see what works:

 

Name:    ntp.ku.ac.th
Address:  158.108.212.149


Name:    th.pool.ntp.org
Address:  124.109.2.169


Name:    fw.eng.ku.ac.th
Address:  158.108.32.17

 

Name:    ilm.live.rmutt.ac.th
Address:  203.158.118.3

 

Name:    time.uni.net.th
Address:  202.28.18.72

 

Name:    itoml.live.rmutt.ac.th
Address:  203.158.111.32
Address: 158.108.7.157
Address: 158.108.2.100

 

Name:    delta.cpe.ku.ac.th
Address:  158.108.32.3

 

Name:   time.navy.mi.th
Address: 203.147.22.16

 

Name:    clock.nectec.or.th
Address:  203.185.67.115

 

Name:    time1.nimt.or.th
Address:  203.185.69.60

 

Name:    time2.nimt.or.th
Address:  203.185.69.59

 

Name:    time3.nimt.or.th
Address:  203.185.69.56

  • Thanks 1
Link to post
Share on other sites

I'm beginning to suspect that 3BB has DNS problems.  I would suggest switching to a well known 3rd party DNS server such as Google @8.8.8.8, Quad9 @ 9.9.9.9 or cloudflare @ 1.1.1.1

  • Like 1
  • Thanks 1
Link to post
Share on other sites
On 5/8/2020 at 2:59 PM, RichCor said:

I remember having NTP issues when relying on 3BB as my primary connection several years ago. 

 

Try pinging any of these and see what works:

 

Name:    ntp.ku.ac.th
Address:  158.108.212.149


Name:    th.pool.ntp.org
Address:  124.109.2.169

Thanks. Tried pinging and some replied but still did not work when I set them to be the time server to sync with. The sync operation times out. With VPN it works.

Link to post
Share on other sites
11 hours ago, gamb00ler said:

I'm beginning to suspect that 3BB has DNS problems.  I would suggest switching to a well known 3rd party DNS server such as Google @8.8.8.8, Quad9 @ 9.9.9.9 or cloudflare @ 1.1.1.1

I tried your suggestion but no luck so far. Its like the request goes out ok to the time servers but the return packets get blocked.

Link to post
Share on other sites

Sounds very likely that 3BB is blocking ntp port 123.

 

As you probably already know, it's best if your Internet connected devices have the correct local time for secure trust encryption to operate.

 

You could message 3BB and ask, or as an alternative download and run a third-party app in the background. Google Search: Alternative to System Time & NTP  

  • Thanks 1
Link to post
Share on other sites

It's more likely your requests are being blocked by the NTP server administrator, or automatically, for abuse. Abuse would simply be querying the time server more than a specified number of times per hour, for example. Perhaps you have copied and pasted the address of a timer server you found online, without realising it might be a 'closed server' i.e. you may only use it by invitation or request. You are probably just blocked. It's also possible you copy/pasted a server that simply doesn't exist anymore. It is not sufficient to ping the server, this is a completely different protocol being replied to (ICMP). You MUST query with the actual NTP protocol to see if it is live for time queries, just because it answers to ping doesn't mean it's answering to NTP. Many of the servers posted above just don't work, you can check if the NTP server is live here. . .

 

https://servertest.online/ntp

 

There may also be geographic restriction on private time servers, which is why you might find it works with/out a VPN. It's almost certainly not a DNS problem.

 

The best the average use can do is use the NTP pool, rather than any specific servers. . .

 

0.pool.ntp.org

 

You will automatically be directed to the nearest available server by the NTP project's DNS systems. However, you can specify more local pools like so. . .

 

3.th.pool.ntp.org
3.asia.pool.ntp.org
0.asia.pool.ntp.org

 

There are some privately operated servers in Thailand, but there aren't many, will mostly be closed access and are mostly university servers, or completely private, and you risk being blocked, as I describe above, if you don't seek permission to query them first. However, if you have permission, you might want to use them because they are a higher stratum (i.e. how many levels from the original time source) than you might otherwise get with a pool. For example. . .

 

(snip, I decided to delete my list of private servers. PM me if you want them)

 

I would advise you NOT to use or specify a Thailand based time server, simply because, like so many things here, they are usually poorly maintained or just plain unreliable.

 

 

Edited by NilSS
  • Thanks 1
Link to post
Share on other sites

. . . actually, don't PM me. You can read a list of working high stratum servers here, but be aware, they are mostly closed access. Just use the NTP Pool, unless you have a niche use case. . .

 

Stratum one. . .

https://support.ntp.org/bin/view/Servers/StratumOneTimeServers

 

Stratum two. . .

http://support.ntp.org/bin/view/Servers/StratumTwoTimeServers

 

 

 

 

Edited by NilSS
  • Thanks 1
Link to post
Share on other sites
On 5/9/2020 at 4:31 PM, RichCor said:

Sounds very likely that 3BB is blocking ntp port 123.

 

As you probably already know, it's best if your Internet connected devices have the correct local time for secure trust encryption to operate.

 

You could message 3BB and ask, or as an alternative download and run a third-party app in the background. Google Search: Alternative to System Time & NTP  

I decided to let the clock attempt to sync with time servers automatically without me forcing it for a few days but still no luck. Today I spent way too much time digging around and finally configured the 3BB device to forward port 123 and was successful. Strange because I had disabled its firewall as part of the troubleshooting process but it still wouldn't let the traffic through until I did the port forward rule.

 

Thanks to everyone for all the helpful hints. Here's the details in case someone runs into the problem.

Huawei HG8145V5 ONT
Forward Rules > Port Trigger Configuration
New Rule
Trigger Protocol: TCP/UDP
Open Protocol: TCP/UDP
Start Trigger Port: 123
End Trigger Port: 123
Start Open Port: 123
End Open Port: 123
Apply

  • Like 1
Link to post
Share on other sites
  • 9 months later...
On 5/17/2020 at 4:10 PM, KeeTua said:

I decided to let the clock attempt to sync with time servers automatically without me forcing it for a few days but still no luck. Today I spent way too much time digging around and finally configured the 3BB device to forward port 123 and was successful. Strange because I had disabled its firewall as part of the troubleshooting process but it still wouldn't let the traffic through until I did the port forward rule.

 

Thanks to everyone for all the helpful hints. Here's the details in case someone runs into the problem.

Huawei HG8145V5 ONT
Forward Rules > Port Trigger Configuration
New Rule
Trigger Protocol: TCP/UDP
Open Protocol: TCP/UDP
Start Trigger Port: 123
End Trigger Port: 123
Start Open Port: 123
End Open Port: 123
Apply

Wow, thank you so much! 

I'm using 3BB and have the exact same issue that is now solved by your contribution.
I've browsed thaivisa before but I've registered an account just to say thank you very much.

  • Like 1
Link to post
Share on other sites
On 2/19/2021 at 2:29 PM, David C Y said:

Wow, thank you so much! 

I'm using 3BB and have the exact same issue that is now solved by your contribution.
I've browsed thaivisa before but I've registered an account just to say thank you very much.

You're welcome. I'm glad it worked for you too.

Link to post
Share on other sites

Could anyone please help a non-expert (I consider accessing the router a major achievement😀) configuring my device? I have the same 3BB synch issue and am not exactly sure how to enter the data kindly listed by KeeTua above.

3bb.JPG

 

3bb2.JPG

Edited by Inderpland
Link to post
Share on other sites

I reckon it would be a description in first field, "timesync" whatever you want

123-123

trigger protocol all

123-123

then enable

then apply

  • Like 2
Link to post
Share on other sites
3 hours ago, Inderpland said:

Could anyone please help a non-expert (I consider accessing the router a major achievement😀) configuring my device? I have the same 3BB synch issue and am not exactly sure how to enter the data kindly listed by KeeTua above.

Your port trigger configuration page is a little different than mine because its a different model of router. What Kekalot posted is correct for your router. Hope this works for you too!

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...
On 2/23/2021 at 12:56 PM, kekalot said:

I reckon it would be a description in first field, "timesync" whatever you want

123-123

trigger protocol all

123-123

then enable

then apply

 

On 2/23/2021 at 2:02 PM, KeeTua said:

Your port trigger configuration page is a little different than mine because its a different model of router. What Kekalot posted is correct for your router. Hope this works for you too!

I tried putting in what kekalot suggested but no luck so far. Did restart the router and the PC before I tried. Any last suggestions before I just give up and continue on manual time?😁

 

 

Router.JPG

Synch.JPG

Link to post
Share on other sites
1 hour ago, Inderpland said:

Any last suggestions before I just give up and continue on manual time?

Tick the little box next to 'Enable' then click apply.

Link to post
Share on other sites

I took a look this morning at my port triggering rule and that box I suggested you tick is just for selecting the rule. It looks like your 'Timesynch' rule is correctly configured and already enabled. Sorry any for confusion that my above post may have caused.

Link to post
Share on other sites
1 hour ago, KeeTua said:

I took a look this morning at my port triggering rule and that box I suggested you tick is just for selecting the rule. It looks like your 'Timesynch' rule is correctly configured and already enabled. Sorry any for confusion that my above post may have caused.

No worries, I did tick it off even before reading your post and clicked apply and that makes the tick-off disappear. Thanks for trying to help though!😀

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...