Jump to content
BANGKOK
Inderpland

Sick and tired of mobile data switching on

Recommended Posts

Time after time I lose all the money on my prepaid DTAC card because for some reason the mobile data has switched itself on. I even have an app that's supposed to give me better control but that didn't prevent the money from being drained yet again.

My question is; what can I do? I'm looking for an app to password protect switching the damn thing on but haven't found anything. Any other options short of keeping no money in the card?

Share this post


Link to post
Share on other sites

I used to have that problem with a Samsung phone. If you are running a Samsung check the "Smart Network" settings.

 

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Dumbastheycome said:

I used to have that problem with a Samsung phone. If you are running a Samsung check the "Smart Network" settings.

 

i was just about to edit to mention that
called wifi+ on huawei phones, although it looks like they have removed it on huawei recently
as i could no longer find it in settings

if the phone has something named similar,
better to disable it as it switches the phone to mobile data when wifi drops.

Also delete any apps you have installed for this,
as they are not needed and may actually be cause of the issue.

  • Like 1

Share this post


Link to post
Share on other sites
11 minutes ago, innosiem said:

Settings > mobile network > Mobile data > disable.

This is the exact setting that keeps switching itself back on, not frequently but one every 1 to 2 months.

Share this post


Link to post
Share on other sites
8 minutes ago, innosiem said:

i was just about to edit to mention that
called wifi+ on huawei phones, although it looks like they have removed it on huawei recently
as i could no longer find it in settings

if the phone has something named similar,
better to disable it as it switches the phone to mobile data when wifi drops.
 

It's disabled.

Share this post


Link to post
Share on other sites
25 minutes ago, Inderpland said:

This is the exact setting that keeps switching itself back on, not frequently but one every 1 to 2 months.

what version android you running ?

if its only once every 1-2 months
i would expect it may revert to "on"
after an OS update

as i said, you don't need apps for this, so first thing i would do is uninstall any apps that could interfere

Share this post


Link to post
Share on other sites

I found that I had this problem last week when I asked DTAC why my last three lots of credit had disappeared - the first two I couldn't swear I hadn't used the phone for calls or SMS so I made sure the third time I topped it up I didn't use it and checked the balance every morning so I could catch whatever it was.  I had data turned off and couldn't understand it.  The only time I've actually turned mobile data on was to check-in at Big C on the first day we were allowed back in shops, learnt the hard way that it's much easier to write my name and number in the book if you don't have data on all the time.  It was definitely off, and had only ever been on for long enough for me to 'check-in'.

 

Got in touch with them and it turns out that as well as turning off mobile data, you have to restrict mobile data by each app.  It was too tedious, so instead I used the DTAC control they suggested.  Dial *104*72*9# and it's off.  If you want to turn it back on at any time in the future, dial *104*71*9#.

 

Definitely works, my balance hasn't moved since I did it last Monday.  The speed of the response with details to turn off background use suggests to me that they are getting a lot of queries about this.

 

(This is the second time this year I've had to contact them, a few months ago the One Time Passcodes from my bank in Australia weren't getting through, they had changed something and fixed it pretty much straight away.  I used Facebook Messenger both times to contact them, whoever is answering the messages on there is doing a really good job of explaining/fixing things.  I don't use Facebook, just messenger and it's really handy for contacting companies and getting quick solid replies in most cases.)

 

This should fix it for you, but if you think you will ever need it again in future keep a note of the number to turn it back on.

  • Like 1

Share this post


Link to post
Share on other sites
46 minutes ago, Inderpland said:

This is the exact setting that keeps switching itself back on, not frequently but one every 1 to 2 months.

 

There is a simple solution. Apply 40 baht of credit to your account and then enter *103*55*9# and then hit the Dial key. That will apply an 'always on' data connection of 64 kbps...forever. So no more exces charges for data. Ever.

Of course you could be one of those who would rather bite your nose off to spite your face, rather than having to pay to fix the issue.

 

So in that case your solution would be to simply switch data off at the source. *104*72*9# then the Dial key.

*104*71*9# Dial key to switch it back on.

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Konini said:

I found that I had this problem last week when I asked DTAC why my last three lots of credit had disappeared - the first two I couldn't swear I hadn't used the phone for calls or SMS so I made sure the third time I topped it up I didn't use it and checked the balance every morning so I could catch whatever it was.  I had data turned off and couldn't understand it.  The only time I've actually turned mobile data on was to check-in at Big C on the first day we were allowed back in shops, learnt the hard way that it's much easier to write my name and number in the book if you don't have data on all the time.  It was definitely off, and had only ever been on for long enough for me to 'check-in'.

 

Got in touch with them and it turns out that as well as turning off mobile data, you have to restrict mobile data by each app.  It was too tedious, so instead I used the DTAC control they suggested.  Dial *104*72*9# and it's off.  If you want to turn it back on at any time in the future, dial *104*71*9#.

 

Definitely works, my balance hasn't moved since I did it last Monday.  The speed of the response with details to turn off background use suggests to me that they are getting a lot of queries about this.

 

(This is the second time this year I've had to contact them, a few months ago the One Time Passcodes from my bank in Australia weren't getting through, they had changed something and fixed it pretty much straight away.  I used Facebook Messenger both times to contact them, whoever is answering the messages on there is doing a really good job of explaining/fixing things.  I don't use Facebook, just messenger and it's really handy for contacting companies and getting quick solid replies in most cases.)

 

This should fix it for you, but if you think you will ever need it again in future keep a note of the number to turn it back on.

 

There is another solution, as detailed in the post above yours. 

Share this post


Link to post
Share on other sites
2 hours ago, innosiem said:

what version android you running ?

if its only once every 1-2 months
i would expect it may revert to "on"
after an OS update

as i said, you don't need apps for this, so first thing i would do is uninstall any apps that could interfere

I think you're onto something. Just yesterday I installed a system update.

Share this post


Link to post
Share on other sites
2 hours ago, Eindhoven said:

 

There is a simple solution. Apply 40 baht of credit to your account and then enter *103*55*9# and then hit the Dial key. That will apply an 'always on' data connection of 64 kbps...forever. So no more exces charges for data. Ever.

Of course you could be one of those who would rather bite your nose off to spite your face, rather than having to pay to fix the issue.

Would I still be able to buy packages like X GB for X days which I sometimes have to do when travelling?

Share this post


Link to post
Share on other sites
2 hours ago, Inderpland said:

Would I still be able to buy packages like X GB for X days which I sometimes have to do when travelling?

 

Yes, they remain unaffected. The difference being, that when they run out, it will fall back to the 64 kbps connection. 

It will continue for at least a year. After that you may need to do a top up of at least 10 baht perhaps per month to keep extending the plan for another year. The top-ups stay as credit, as there is no cost to extend.

It's a good solution, as you'll find that you can still use Chat Apps on that slow connection, albeit just for text and not photos etc

Just add a pack if you need high speed.

Share this post


Link to post
Share on other sites

Think it's only 350bht unlimited Internet 512 for a month. No GB limits. But if its a preferable choice by you then to not have it always on then ok. I never heard of data switching itself on. Only if you change simcards then it could happen

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...