Jump to content

Problem displaying subtitles


Recommended Posts

My TV is a Panasonic (Viera)  Model: TH-P42XT50T.

Usually when watching a film via the USB I can get the any subtitles to display OK.

 

I've started watching Caliphate, a Swedish language series with multiple subtitles (29 different language options).

When watching on my laptop using VLC, it displays the English subtitles fine.

 

If I use my TV to watch exactly the same files (all .mkv), apart from offering only eight of the 29 subtitle options, any one of those eight I select displays showing erroneous data - string of digits before the text.

See the attached image.

 

My TV has an ethernet internet connection. I've used that to update the TV software to the latest option.

 

I don't suppose anyone knows any way to correct this on the TV?

20200908_092231.jpg

 

Edited by bluesofa
misprit
Link to post
Share on other sites
  • Replies 39
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Not a cure for the TV itself, but if the subs display correctly on the laptop then why not just feed the laptop signal to the TV via HDMI?

Some televisions use text recognition for subtitles.  Try renaming the subtitle file to *.txt, rather than *.srt, and use notepad to remove all formatting in the file before playing it.

I took your advice and looked for another d/l source. Found some Russian sites and just d/l everything there was for Kalifat  (Caliphate).   The first one to complete had only Russian a

Posted Images

31 minutes ago, dddave said:

Not a cure for the TV itself, but if the subs display correctly on the laptop then why not just feed the laptop signal to the TV via HDMI?

True, that's one way around it. Some lateral thinking there.

 

My laptop battery hasn't worked for years, it's in another room connected to a UPS. It would mean every time I'd need to stop & restart the laptop. Plus I'd have to buy an HDMI lead.

It's the first time I've seen this particular subtitle error, so was keen to find out if I could solve the issue.

 

Thanks again for the suggestion.

 

Edited by bluesofa
Link to post
Share on other sites

Are the subtitles included/encoded into the MKV file or separate subtitle  (test) files ?

possibly your TV cannot display the character set that the subtitles use..if using seperate text files then its quite easy to use a program like "subtitle edit"  to check and fix problems and character sets...if they are encoded into the MKV then  not so easy.

Link to post
Share on other sites
11 minutes ago, johng said:

Are the subtitles included/encoded into the MKV file or separate subtitle  (test) files ?

possibly your TV cannot display the character set that the subtitles use..if using seperate text files then its quite easy to use a program like "subtitle edit"  to check and fix problems and character sets...if they are encoded into the MKV then  not so easy.

The subtitles are encoded into the .mkv file - no separate files.

 

Could be a limitation of the TV software, perhaps scared it seeing 29 subtitled languages (even though it only listed eight)!

 

By coincidence, I happen to have The Whole Ten Yards on the same USB. That's also an .mkv file, with subtitles. However, that only has English as the one option language. It displays fine.

Link to post
Share on other sites
2 minutes ago, bluesofa said:

The subtitles are encoded into the .mkv file - no separate files.

You could try downloading the separate  .srt files  from  someplace like opensubtitles.com

into the same folder as the video files

name or rename them exactly as your video files are named except for the .mkv extension 

will now be .eng.srt    see if the TV likes them better. 

Link to post
Share on other sites
1 hour ago, petermik said:

I had a similar problem on my new Samsung TV..the problem is some MKV files are ok others are not...solution for me is that now if my dl,s are MKV I now convert them to MP4 with this free programe..https://www.pazera-software.com/products/avi-to-mp4-converter/....

used it often a great tool :thumbsup:

I tried one file. It converted and it plays OK. Took over forty minutes to convert a forty-five minute episode.

However, all of the subtitles are now missing that were encoded in the .mkv file.

Unless I've missed something?

 

Link to post
Share on other sites

use mkvtoolnix to add/remove subtitles and sound tracks to your video files as needed.

 

.srt files might work if playing from a USB source, but won't work if using a DLNA server, because DLNA only streams one file at a time. For DLNA it's necessary to nix the subs into the mkv container.

Link to post
Share on other sites
2 hours ago, johng said:

You could try downloading the separate  .srt files  from  someplace like opensubtitles.com

into the same folder as the video files

name or rename them exactly as your video files are named except for the .mkv extension 

will now be .eng.srt    see if the TV likes them better. 

Thanks for the suggestion.

I did try that. I d/l the subtitle for one episode.

Put it in the same folder as all the .mkv files for the series.

I renamed it the same as the video file, except with .srt as the suffix. On my TV it showed a subtitle file listed as a dash -  but couldn't open it.

I realised I hadn't renamed the suffix as you had said - .eng.srt  I did that, but then it ignored it completely and offered me the original embedded subtitles.

Where am I going wrong doctor?

Link to post
Share on other sites
2 minutes ago, bluesofa said:

I realised I hadn't renamed the suffix as you had said - .eng.srt  I did that, but then it ignored it

try renaming  ( a copy of ) one episode as  1.mkv   and the subtitle file as 1.srt

sometimes certain devices don't like underscores _ dashes - too many  points. hashes #  and many other characters, to long filenames and filenames with  different character sets,  maybe the creator of the files used Swedish character set on their computer and the TV is confused

( I mean who isn't confused by Swedish language  😋 )

Link to post
Share on other sites
13 minutes ago, johng said:

try renaming  ( a copy of ) one episode as  1.mkv   and the subtitle file as 1.srt

sometimes certain devices don't like underscores _ dashes - too many  points. hashes #  and many other characters, to long filenames and filenames with  different character sets,  maybe the creator of the files used Swedish character set on their computer and the TV is confused

( I mean who isn't confused by Swedish language  😋 )

OK Herr Docktor, I have followed your instructions.

Renamed video file & subtitle file just as '1' plus the suffixes - 1.mkv and 1.srt

 

It was the same as the first time - the TV offered a subtitle file as a dash -

I don't know if that's because there was no language before the .srt? So I did the same again - 1.eng.srt. Again that meant it ignored it completely and offered the embedded subtitles in the .mkv file.

 

I've pulled most of my hair out so far. What do I need to do to get rid of the remainder?

 

Link to post
Share on other sites

Some televisions use text recognition for subtitles.  Try renaming the subtitle file to *.txt, rather than *.srt, and use notepad to remove all formatting in the file before playing it.

  • Like 1
Link to post
Share on other sites

Ok something else to try   take a copy of  one episode of  "The Whole Ten Yards"    and rename it to 2.mkv  and rename the subtitle file for Caliphate to 2.srt   change the subtitle selection  and see if the "wrong"

dialogue appears...this will prove the TV can actually recognise and play .srt files...there are other formats too like .ssa  that the TV might work with ( needs downloading again )

make sure   movie file and subtitle file are both in their own folder/directory   not all muddled up  in one directory.

Link to post
Share on other sites

If your TV gets confused by too many subs, you can delete the sub files you don't want by using the MKVTool Nix:- https://www.fosshub.com/MKVToolNix.html.

 

Drag the movie file onto the program and it will display all the sub and audio files, then uncheck the ones you don't want choose a destination and "Start Multiplexing"

 

It only takes a few moments as its just removing the selected files not converting the whole movie.

Capture.jpg.5cc8950e39993a9db2bc1f055e9471e5.jpg 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...