Jump to content

Problem displaying subtitles


Recommended Posts

1 hour ago, ballpoint said:

Some televisions use text recognition for subtitles.  Try renaming the subtitle file to *.txt, rather than *.srt, and use notepad to remove all formatting in the file before playing it.

I tried renaming it to .txt, but it ignored it.

I don't understand about removing formatting. It looks to me like there's time stamps in there maybe to tell it when to show the text?

 

 

Link to post
Share on other sites
  • Replies 39
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Not a cure for the TV itself, but if the subs display correctly on the laptop then why not just feed the laptop signal to the TV via HDMI?

Some televisions use text recognition for subtitles.  Try renaming the subtitle file to *.txt, rather than *.srt, and use notepad to remove all formatting in the file before playing it.

I took your advice and looked for another d/l source. Found some Russian sites and just d/l everything there was for Kalifat  (Caliphate).   The first one to complete had only Russian a

Posted Images

1 hour ago, johng said:

Ok something else to try   take a copy of  one episode of  "The Whole Ten Yards"    and rename it to 2.mkv  and rename the subtitle file for Caliphate to 2.srt   change the subtitle selection  and see if the "wrong"

dialogue appears...this will prove the TV can actually recognise and play .srt files...there are other formats too like .ssa  that the TV might work with ( needs downloading again )

make sure   movie file and subtitle file are both in their own folder/directory   not all muddled up  in one directory.

I did that and it successfully showed the The Whole Ten Yards with the subtitles for a Caliphate episode I'd d/l earlier.

So it proves that works.

Both were in one folder with the same file name and .mkv and .srt suffixes.

 

The Whole Ten Yards has only one subtitle language embedded in the .mkv file, whereas Caliphate has 29. Maybe that's not helping?

 

Edited by bluesofa
Link to post
Share on other sites

You could get a cheap android box and use VLC player. Decodes pretty much anything. You then have a box which you can load plenty more apps, far more smarter than a TV.

Link to post
Share on other sites
52 minutes ago, Daffy D said:

If your TV gets confused by too many subs, you can delete the sub files you don't want by using the MKVTool Nix:- https://www.fosshub.com/MKVToolNix.html.

 

Drag the movie file onto the program and it will display all the sub and audio files, then uncheck the ones you don't want choose a destination and "Start Multiplexing"

 

It only takes a few moments as its just removing the selected files not converting the whole movie.

Capture.jpg.5cc8950e39993a9db2bc1f055e9471e5.jpg 

Thanks for replying.

I d/l the program. Fortunately they have a Linux version too, so I didn't need to boot Windows.

 

I ran it, removed all the subtitles apart from two English versions.

It ran on the TV OK afterwards. Sadly, the subtitles still have those digits being displayed.

I was really hopeful, especially as it was straightforward to remove all the couple of dozen subtitles.

 

Oh well. Thanks again.

 

Link to post
Share on other sites
28 minutes ago, sungod said:

You could get a cheap android box and use VLC player. Decodes pretty much anything. You then have a box which you can load plenty more apps, far more smarter than a TV.

OK.

Although even the 'cheap' option would involve spending money, which is a no-no for me.

Thanks for the suggestion though.

Link to post
Share on other sites
24 minutes ago, johng said:

So now try that new file that MKVtool made with the external .srt file

I've tried.

I removed the original English subtitles and added the d/l subs,but I just don't know enough about the program to add a subtitle file. It keeps failing.

 

 

Link to post
Share on other sites
1 hour ago, bluesofa said:

I tried renaming it to .txt, but it ignored it.

I don't understand about removing formatting. It looks to me like there's time stamps in there maybe to tell it when to show the text?

 

 

Can you post a short section of the srt file?  The digits you show in the example on the first page look similar to the time stamp that should be before every line of dialogue, but aren't quite in the correct format.

image.png.31635f4d2ae5d492832918bbe4a4c2b3.png

An srt time stamp should be hr:min:sec,msec-->hr:min:sec,msec for the times to start and stop showing the dialogue.

image.png.c10311054bbbb7e79c4a1b908818d353.png

It would be interesting to see if yours has the same format.

 

Link to post
Share on other sites

I don't have any .srt files to show, the 29 subtitles are embedded in the .mkv file.

I dunno why VLC displays it correctly but my TV doesn't.

You can have look if you want and can dissect it. On tpb Spud17 has it there with multi-subs.

Link to post
Share on other sites

Just a thought 

 

On my Samsung TV there is the option of what language to display subs.

 

Maybe your TV is set to display a different language and that is giving you the wrong read out.

 

:unsure: 

Link to post
Share on other sites
29 minutes ago, Daffy D said:

Just a thought 

 

On my Samsung TV there is the option of what language to display subs.

 

Maybe your TV is set to display a different language and that is giving you the wrong read out.

 

:unsure: 

Oh dear! This is becoming an epic!

I'm pleased for all the help I've received about this.

Right, here are two pics.

 

Subtitles-Embedded.thumb.jpg.5d26f2bacafb5b928f0daa2540b63730.jpg

This one above is from my TV when using the embedded 29 subtitles in the .mkv file.

 

 

 

 

Subtitles-SRT-file.thumb.jpg.df36d16d4fb3ebabd476fc5600300d4f.jpg

This one above is when using an external .srt file. It's only in this case I can select the character set.

 

 

While we're on this subject, I've found that by removing ALL the embedded subs using MKVToolNix, only then can I get the .srt file to display, and correctly.

 

The only thing is, the sub text is rather small, so now I've been trying to see if I can enlarge it.

I googled, and someone suggested using html in the .srt files.

 

I tried that. It worked fine with VLC - larger text and changed from default white to yellow (but only on the first line of subtitles where I tested it. I assume I'd need to specify it for every line)

However, when I view it on the TV, it ignores the html code and just displays the html as subtitle text.

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...