Jump to content
BANGKOK 19 June 2019 18:34
Sign in to follow this  
Johpa

Small Thai Fonts

Recommended Posts

When people post in Thai script that script does show up on my computer. But often it is so small that I can't even begin to read it, not with these aging middle-aged eyes and bifocals. If there any way to increase the font size on postings.

I usually use Firefox for a Web browser if that is a factor.

And since the browser shows Thai script does that mean I might have the potential, with the help of a keyboard overlay, to actually post using Thai fonts?

Share this post


Link to post
Share on other sites
When people post in Thai script that script does show up on my computer.  But often it is so small that I can't even begin to read it, not with these aging middle-aged eyes and bifocals.  If there any way to increase the font size on postings.

There is a size tag that can be used to change the size of a piece of text. It does rely on posters disciplining themselves, but one can always go back and edit posts if you forget to enlarge the font. It's not so friendly; you have to terminate the enlarged region by manually typing [/size] or 'closing all tags'.

Standard size: อ่านได้ไหม

Small size: อ่านได้ไหม

Large size (i.e. 7): อ่านได้ไหม

Largest size (i.e. 14): อ่านได้ไหม

Size 8: อ่านได้ไหม

Size 6: อ่านได้ไหม

Size 5: อ่านได้ไหม

Size 4: อ่านได้ไหม

I usually use Firefox for a Web browser if that is a factor.

And since the browser shows Thai script does that mean I might have the potential, with the help of a keyboard overlay, to actually post using Thai fonts?

It may depend on your operating system and whether you are in control of the PC. I knocked up an IE HTML/Javascript page for when your PC administrators don't let you type Thai. It's clumsy in that you have to cut and paste, but that's not usually a significant limitation for this forum. I don't know whether it works with Firefox.

Edited by Richard W

Share this post


Link to post
Share on other sites
When people post in Thai script that script does show up on my computer.  But often it is so small that I can't even begin to read it, not with these aging middle-aged eyes and bifocals.  If there any way to increase the font size on postings.

I usually use Firefox for a Web browser if that is a factor.

And since the browser shows Thai script does that mean I might have the potential, with the help of a keyboard overlay, to actually post using Thai fonts?

Additional to Richard W's reply, have you got the "Thai Text Service" installed? If so, you can use the 'On-Screen Keyboard' to type in Thai. (Start, Programs, Accessories, Accessibilty, On Screen Keyboard).

If not, in Windows XP, go to Control Panel, Regional and Language Options, Languages. Check the 'Install files for complex script...'.

You will also need to click "Details" and then "Add" and select "Thai" input language.

I did this a long time ago, and am not sure of the order that the above must be done. Search the entire forum for "OSK" or "On Screen Keyboard" - I'm sure it's been discussed before.

And I always use size=7 when I post Thai words

โรเงอร์

Share this post


Link to post
Share on other sites
And I always use size=7 when I post Thai words

    โรเงอร์

I feel size=7 is too big; I would prefer size=4 or size=5. What do you think, Johpa?

RDN, why โรเจอร์ rather than รอเจอร์? I think เรา็็็็็็็็็็็็ะ็็็็็็็็็็็็็็็เจ็อร์ would be better, but the Royal Institute wouldn't approve that one.

Share this post


Link to post
Share on other sites
And I always use size=7 when I post Thai words

    โรเงอร์

I feel size=7 is too big; I would prefer size=4 or size=5. What do you think, Johpa?

RDN, why โรเจอร์ rather than รอเจอร์? I think เรา็็็็็็็็็็็็ะ็็็็็็็็็็็็็็็เจ็อร์ would be better, but the Royal Institute wouldn't approve that one.

I guess if I was American, then I might spell it รอเจอร์ because that would make it sound like "Rar-ger", rather than "Ror-ger" - that's according to my g/f.

And เรา็็็็็็็็็็็็ะ็็็็็็็็็็็็็็็เจ็อร์ would sound more like "Ru-ger" ('Ru' as in 'Ruck') - again, according to my g/f.

I can't actually remember who first wrote my name in Thai - maybe my teacher, maybe the girl who writes the names up on the pool table waiting list... :o

P.S. I use size=7 to make the Thai words bigger than the Roman, so the small tone marks and vowels can be seen. I know they don't fit with the size of the Roman letters, but on the other hand I don't have to squint to read them! :D

P.P.S. I just noticed I spelt it wrong on my original post! I put instead of . Thanks for ignoring it, or maybe you didn't notice either? :D

Share this post


Link to post
Share on other sites
P.P.S. I just noticed I spelt it wrong on my original post! I put    instead of . Thanks for ignoring it, or maybe you didn't notice either?  :o

I didn't notice it at first. I think the loop of the must have looked solid. It's one of the letters you have to adjust to when reading a new font or handwriting style. It then stuck out when I had the alternative transliterations to compare it with. I don't know what's happening with the rendering here - the size 5 character looks quite different to the size 7 character - - and is actually more distinctive!

Share this post


Link to post
Share on other sites
P.P.S. I just noticed I spelt it wrong on my original post! I put    instead of . Thanks for ignoring it, or maybe you didn't notice either?  :D

I didn't notice it at first. I think the loop of the must have looked solid. It's one of the letters you have to adjust to when reading a new font or handwriting style. It then stuck out when I had the alternative transliterations to compare it with. I don't know what's happening with the rendering here - the size 5 character looks quite different to the size 7 character - - and is actually more distinctive!

size=1....... โรเจอร์

size=2....... โรเจอร์

size=3....... โรเจอร์

size=4....... โรเจอร์

size=5....... โรเจอร์

size=6....... โรเจอร์

size=7....... โรเจอร์

size=8....... โรเจอร์

size=9....... โรเจอร์

size=10..... โรเจอร์

size=11..... โรเจอร์

size=12..... โรเจอร์

size=13..... โรเจอร์

size=14..... โรเจอร์

Yes, size 5 looks quite clear, apart from the gaa-ran over the final raw reua. After 5, the fonts get thicker, thus removing some of the clarity. Of course, if you increase the text size in your browser, everything changes!

Actually size 12 looks quite clear.... :o

Share this post


Link to post
Share on other sites
When people post in Thai script that script does show up on my computer.  But often it is so small that I can't even begin to read it, not with these aging middle-aged eyes and bifocals.  If there any way to increase the font size on postings.

I usually use Firefox for a Web browser if that is a factor.

And since the browser shows Thai script does that mean I might have the potential, with the help of a keyboard overlay, to actually post using Thai fonts?

Additional to Richard W's reply, have you got the "Thai Text Service" installed? If so, you can use the 'On-Screen Keyboard' to type in Thai. (Start, Programs, Accessories, Accessibilty, On Screen Keyboard).

If not, in Windows XP, go to Control Panel, Regional and Language Options, Languages. Check the 'Install files for complex script...'.

You will also need to click "Details" and then "Add" and select "Thai" input language.

I did this a long time ago, and am not sure of the order that the above must be done. Search the entire forum for "OSK" or "On Screen Keyboard" - I'm sure it's been discussed before.

And I always use size=7 when I post Thai words

โรเงอร์

RDN~

I have the "On-Screen Keyboard" feature here running XP Pro but everytime I have it up and running and try to type in Thai, it defaults to English?

BTW, thanks for all the good info on font sizes but the signature line does not display w/out the "size" tag included? Tried "closing all tags"...

Cheers,

บุญมี

Share this post


Link to post
Share on other sites
RDN~

I have the "On-Screen Keyboard" feature here running XP Pro but everytime I have it up and running and try to type in Thai, it defaults to English?

BTW, thanks for all the good info on font sizes but the signature line does not display w/out the "size" tag included?  Tried "closing all tags"...

Cheers,

บุญมี

Do you have the language icon "EN" or "TH" displayed on your "task bar"?

When I click on "EN", I get a list of the "installed services" (English - United States, English - United Kingdom, and Thai). If I click on "Thai" the language displayed on my task bar changes from "EN" to "TH" and the On-Screen-Keyboard characters change. Does this happen on your PC?

ฺBy the way, I think you MUST be in a text box for the language to change - so open up the "Reply" box and click inside it before attempting to change the language.

Not sure what you mean about the signature line. I see your name in large font, but not your signature. It's probably not allowed or over-ridden by the forum software if you put the "size" code in your signature. :o

Edit:

OK, I just tried to add "size=7" to my signature - software won't let me, you actually see the code "" as part of the signature.

Edited by RDN

Share this post


Link to post
Share on other sites
size=1....... โรเจอร์

size=2....... โรเจอร์

size=3....... โรเจอร์

size=4....... โรเจอร์

size=5....... โรเจอร์

size=6....... โรเจอร์

size=7....... โรเจอร์

size=8....... โรเจอร์

size=9....... โรเจอร์

size=10..... โรเจอร์

size=11..... โรเจอร์

size=12..... โรเจอร์

size=13..... โรเจอร์

size=14..... โรเจอร์

Yes, size 5 looks quite clear........

On my screen, it is really only legible from size 7 on up.

Share this post


Link to post
Share on other sites
RDN~

I have the "On-Screen Keyboard" feature here running XP Pro but everytime I have it up and running and try to type in Thai, it defaults to English?

BTW, thanks for all the good info on font sizes but the signature line does not display w/out the "size" tag included?  Tried "closing all tags"...

Cheers,

บุญมี

Do you have the language icon "EN" or "TH" displayed on your "task bar"?

When I click on "EN", I get a list of the "installed services" (English - United States, English - United Kingdom, and Thai). If I click on "Thai" the language displayed on my task bar changes from "EN" to "TH" and the On-Screen-Keyboard characters change. Does this happen on your PC?

When I click on "English", all that's displayed is (United States) but I seem to have corrected the other problem where the on screen keyboard was hanging up. If I have MS Word running first I get Thai fonts displayed on the on screen display although they're a bit blurry.

ฺBy the way, I think you MUST be in a text box for the language to change - so open up the "Reply" box and click inside it before attempting to change the language.

Not sure what you mean by the "Repy" box...

Not sure what you mean about the signature line. I see your name in large font, but not your signature. It's probably not allowed or over-ridden by the forum software if you put the "size" code in your signature. :o

Perhaps one of the Mods can sort this one out.

Thanks for all the good help, RDN

บุญมี

Share this post


Link to post
Share on other sites
When I click on "English", all that's displayed is (United States) but I seem to have corrected the other problem where the on screen keyboard was hanging up.  If I have MS Word running first I get Thai fonts displayed on the on screen display although they're a bit blurry.

ฺBy the way, I think you MUST be in a text box for the language to change - so open up the "Reply" box and click inside it before attempting to change the language.

Not sure what you mean by the "Repy" box...

Perhaps one of the Mods can sort this one out.

Thanks for all the good help, RDN

บุญมี

By "Reply" box, I meant the box that opens when you are replying to a post on Thaivisa forum. It is just below the line labelled "Enter your Post". But as you have "Word" running, it appears that you can change language without problems.

I'm curious to know what you do to change the language on your PC, because you say you only get "English (United States)" displayed on your task bar. Can you try to explain?

Cheers

Share this post


Link to post
Share on other sites

By "Reply" box, I meant the box that opens when you are replying to a post on Thaivisa forum. It is just below the line labelled "Enter your Post". But as you have "Word" running, it appears that you can change language without problems.

I'm curious to know what you do to change the language on your PC, because you say you only get "English (United States)" displayed on your task bar. Can you try to explain?

Cheers

RDN~

What I really meant was I've got English (United States) and then "Thai" when I hit the button.

Sorry for the confusion. :o

Share this post


Link to post
Share on other sites
RDN~

What I really meant was I've got English (United States) and then "Thai" when I hit the button. 

Sorry for the confusion. :D

Oh, OK - so everything works OK? I remember taking a long time to get a clear font on my 'On-Screen-Keyboard'. In the end, I settled for a font called "EucrosiaUPC", size 16! :o

- which I got from one of these two sites (can't remember which):

http://www.thailand-uk.com/fonts.html

http://www.thaiphrasebook.com/books/040.php

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...