Jump to content
BANGKOK 23 March 2019 03:36
Marvo

Online 90 day reporting not working now?

Recommended Posts

Any one else unable to "submit" their (tm47) 90 day report online?

I've done it in the past, but this time when clicking on "Submit", I get a new window saying "For further information regarding the 90-day Notification report Service, please contact the Immigration Branch Office in your residence area."

Cheers,

Marvo.

Share this post


Link to post
Share on other sites

That is not a case of the site not working.

That message means your record could not be found or perhaps you are outside the 15 to 7 days before the report date window.

Has anything changed since your last report? New entry, new passport and etc.

Share this post


Link to post
Share on other sites

Joe,

Yes, site seems to be working OK, it just spits out my submission wink.png

Need to report by 4/4/2016 (14 days away).

Reported in person upon arrival 76 days ago.

Same Passport, address etc. Nothing has changed.

Share this post


Link to post
Share on other sites

Joe,

Yes, site seems to be working OK, it just spits out my submission wink.png

Need to report by 4/4/2016 (14 days away).

Reported in person upon arrival 76 days ago.

Same Passport, address etc. Nothing has changed.

Are saying you arrived 76 days ago. That is not doing a report.

Check that you entered everything correctly including your new arrival card number.

You may have to do a mail in report or do one in person since it is your first report after entering the country.

Share this post


Link to post
Share on other sites

So is it the first time you try online report?

My usual checklist:

Just a reminder for entering data on first page:

  • time frame observed: two weeks to one week before due date? (as explained on the help site)
  • ALL CAPITAL LETTERS (is done automatically)
  • only fill fields marked with * (even leave given and middle name empty)
  • observe date order: day / month / year (not US format) and/or use calendar widget
  • nationality from drop down (results in English followed by Thai script), for US: AMERICAN/อเมริกัน, UK: BRITISH/บริติช

One of the worst behaviors of this site: all kinds of errors result in this same generic error message without any hint/reason explained.

Very poor.

  • Like 2

Share this post


Link to post
Share on other sites

So is it the first time you try online report?

My usual checklist:

Just a reminder for entering data on first page:

  • time frame observed: two weeks to one week before due date? (as explained on the help site)
  • ALL CAPITAL LETTERS (is done automatically)
  • only fill fields marked with * (even leave given and middle name empty)
  • observe date order: day / month / year (not US format) and/or use calendar widget
  • nationality from drop down (results in English followed by Thai script), for US: AMERICAN/อเมริกัน, UK: BRITISH/บริติช

One of the worst behaviors of this site: all kinds of errors result in this same generic error message without any hint/reason explained.

Very poor.

BENQ, you genius!

I left out all the information that didn't have a red *asterisk.

No Mr/Mrs, no first name, no middle name, no flight number, and BINGO!!!!!!!!

Done!

  • Like 2

Share this post


Link to post
Share on other sites

No "Mr" is a new degree of minimalism biggrin.png

Good luck to get approval.

  • Like 2

Share this post


Link to post
Share on other sites

So is it the first time you try online report?

My usual checklist:

Just a reminder for entering data on first page:

  • time frame observed: two weeks to one week before due date? (as explained on the help site)
  • ALL CAPITAL LETTERS (is done automatically)
  • only fill fields marked with * (even leave given and middle name empty)
  • observe date order: day / month / year (not US format) and/or use calendar widget
  • nationality from drop down (results in English followed by Thai script), for US: AMERICAN/อเมริกัน, UK: BRITISH/บริติช

One of the worst behaviors of this site: all kinds of errors result in this same generic error message without any hint/reason explained.

Very poor.

BENQ, you genius!

I left out all the information that didn't have a red *asterisk.

No Mr/Mrs, no first name, no middle name, no flight number, and BINGO!!!!!!!!

Done!

My second time trying now, gave up last time after having the same error report over and over. This time I figured they would have fixed whatever problems were on the site last time...

But no, I get the exact same error message as mentioned above. After reading the check list I had my hopes up, but I still get the same error message. I tried leaving out the fields with asterisk and filling them in, even different combinations, before clicking "submit". I tried it in Internet Explorer, but also the IE Chrome tab extension I've been reading about, nothing works.

Last time at the office I tried asking about this but obviously I got nothing back, any suggestions?

Share this post


Link to post
Share on other sites

Get the impression the site, like its human counterpart Somchai

at immigration, suffers easily from system overload. Have tried

to report during daytime and been rebuffed, but got through

when tried in the wee early hours.

Edited by dick turpin

Share this post


Link to post
Share on other sites

This has been a problem for a couple of days now. It won't let you past the 'catcha' page.

Share this post


Link to post
Share on other sites

Same for me but it never worked before. Done it via mail and in person. It's in their database.

But the message pops up way to fast that any countrywide database search could have been done. The entry form does not ask for a location, so it must go to a central server. That should take at least a second or two, not immediately.

Share this post


Link to post
Share on other sites

Same for me but it never worked before. Done it via mail and in person. It's in their database.

But the message pops up way to fast that any countrywide database search could have been done. The entry form does not ask for a location, so it must go to a central server. That should take at least a second or two, not immediately.

It was working OK last week, as two colleagues of mine successfully did theirs online. The fault seems to have started a couple of days ago. It's been mentioned on another thread as well.

Share this post


Link to post
Share on other sites

So is it the first time you try online report?

My usual checklist:

Just a reminder for entering data on first page:

  • time frame observed: two weeks to one week before due date? (as explained on the help site)
  • ALL CAPITAL LETTERS (is done automatically)
  • only fill fields marked with * (even leave given and middle name empty)
  • observe date order: day / month / year (not US format) and/or use calendar widget
  • nationality from drop down (results in English followed by Thai script), for US: AMERICAN/อเมริกัน, UK: BRITISH/บริติช

One of the worst behaviors of this site: all kinds of errors result in this same generic error message without any hint/reason explained.

Very poor.

Genius.

After a year of failed submissions with an unclear error message I got it fixed.

I deleted the flight number and it started working...

I just deleted any non-required fields.

Share this post


Link to post
Share on other sites

So is it the first time you try online report?

My usual checklist:

Just a reminder for entering data on first page:

  • time frame observed: two weeks to one week before due date? (as explained on the help site)
  • ALL CAPITAL LETTERS (is done automatically)
  • only fill fields marked with * (even leave given and middle name empty)
  • observe date order: day / month / year (not US format) and/or use calendar widget
  • nationality from drop down (results in English followed by Thai script), for US: AMERICAN/อเมริกัน, UK: BRITISH/บริติช

One of the worst behaviors of this site: all kinds of errors result in this same generic error message without any hint/reason explained.

Very poor.

Genius.

After a year of failed submissions with an unclear error message I got it fixed.

I deleted the flight number and it started working...

I just deleted any non-required fields.

Also a year of failed submissions. Just tried without completing "not required" fields and straight through, no problem at all!

Well done and thanks BENQ.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...